DeprecationWarning: Python 2.6 is no longer supported by the Python core team

Рубрика: Памятка

На днях при попытке обновить сертификат Let`s Encrypt вылезла ошибка:

DeprecationWarning: Python 2.6 is no longer supported by the Python core team...

Операционная система — CentOS 6.9 x86_64

Решение:

  1. # wget https://www.python.org/ftp/python/2.7.9/Python-2.7.9.tar.xz
  2. # yum install xz
  3. # xz -d Python-2.7.9.tar.xz
  4. # tar -xvf Python-2.7.9.tar
  5. # cd Python-2.7.9
  6. # ./configure --prefix=/usr/local
  7. # make
  8. # make altinstall
  9. # cd /usr/local/bin
  10. # ls python2*
  11. Должен появиться вывод - python2.7  python2.7config
  12. # cd /tmp
  13. # certbot-renew

Стоит заметить, что ошибка при этом не пропала, но сертификт нормально обновился.

 

 

{lang: 'ru'}


Затвитить пост!

Рейтинг:
1 Star (Еще не оценили)
Загрузка...
Популярность: Просмотров: 72
Метки: , ,

Оставить комментарий или два

--> Яндекс.Метрика Рейтинг@Mail.ru